Question

having issues with nginx varnish and wordpress

Hello;

I having having issues with a test server with nginx + varnish and wordpress…

i use this vhost https://github.com/A5hleyRich/wordpress-nginx

everything has been setup but when i change port 80 to 8080 on my website vhost it opens nginx vhost instead of the wordpress blog.

netstat -lntp

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      1450/mysqld
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      2920/nginx -g daemo
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      2920/nginx -g daemo
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      1542/sshd
tcp        0      0 0.0.0.0:6081            0.0.0.0:*               LISTEN      1941/varnishd
tcp        0      0 127.0.0.1:6082          0.0.0.0:*               LISTEN      1941/varnishd
tcp6       0      0 :::80                   :::*                    LISTEN      2920/nginx -g daemo
tcp6       0      0 :::22                   :::*                    LISTEN      1542/sshd
tcp6       0      0 :::6081                 :::*                    LISTEN      1941/varnishd
Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

In the wp-admin Settings area maybe try adding :8080 to the WordPress Address and Site Address fields, so both fields have something like: http://www.domainname.com:8080