hello i just deploy my laravel website and all routes except main "/" give 404 not found

January 24, 2018 1.4k views
Apache LAMP Stack PHP Ubuntu 16.04

laravel.conf

<VirtualHost *:80>
    ServerName mawpro.me

    ServerAdmin webmaster@mawpro.me
    DocumentRoot /var/www/html/library/public

    <Directory /var/www/html/library/public>
        Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
            Require all granted
        </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>


.htaccess


<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews -Indexes
    </IfModule>
    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /


    # Handle Authorization Header
    RewriteCond %{HTTP:Authorization} .
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    # Redirect Trailing Slashes If Not A Folder...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} (.+)/$
    RewriteRule ^ %1 [L,R=301]

    # Handle Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
</IfModule>

2 Answers

Based on what you've shared, my guess would be that your .htaccess file might have permissions set that are preventing apache from reading them. If you created it as the root user this may be the case and running a recursive command to set permissions/ownership in that directory may miss the file since it is hidden.

I would recommend doing:

chown www-data.www-data .htaccess

In the directory where your .htaccess file is located, then restart Apache and see if the problem persists.

having the same problem, did the chown trick, but no change so far...(

Have another answer? Share your knowledge.