any can help me?

I can’t bring my sites back online.
yesterday they were all online.

I installed everyone with this script:
sudo ee site create yoursitename.com –type = wp –ssl = le –cache –yes

the path is / opt / easyengine / sites

I was having trouble with certificate renewal.
I was unable to renew, I tried to use certbot, easyengine, acme.sh ..
I could only renew after creating / etc / nginx / sites-availables blocks

but after I did that, they all went offline.

What did I do? I deleted my sites?
Shouldn’t I have made changes to nginx? since easyengine set it up all by itself?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hey, @wallace11622

Do you see an exact error message when you visit your sites in the browser? Also can you check if nginx is up and running and that there are no errors in the nginx configuration file as well.

To check if nginx is running:

systemctl status nginx

To check for syntax errors:

nginx -t

Looking forward to your reply.

  • all sites currently display this message when trying to access with https: //:
    “Unable to access this site Pietramancini.com connection was denied.
    Try it:

    Check the connection
    Check proxy and firewall
    ERRCONNECTIONREFUSED ”

    and

    display this message when trying to access with http: //:
    “Welcome to nginx!
    If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

    For online documentation and support please refer to nginx.org.
    Commercial support is available at nginx.com.

    Thank you for using nginx. ”

    systemctl status nginx
    

    ● nginx.service - A high performance web server and a reverse proxy server
       Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
       Active: active (running) since Wed 2019-09-25 14:27:15 -03; 1h 46min ago
         Docs: man: nginx (8)
     Main PID: 4562 (nginx)
        Tasks: 2 (limit: 2361)
       CGroup: /system.slice/nginx.service
               45─4562 nginx: master process / usr / sbin / nginx -g daemon on; master_process on;
               └─4565 nginx: worker process

    Sep 25 14:27:15 ubuntu-s-1vcpu-2gb-nyc1-01 systemd [1]: Starting A high performance web server and a reverse proxy server …
    Sep 25 14:27:15 ubuntu-s-1vcpu-2gb-nyc1-01 systemd [1]: nginx.service: Failed to parse PID from file /run/nginx.pid: Invalid argument
    Sep 25 14:27:15 ubuntu-s-1vcpu-2gb-nyc1-01 systemd [1]: Started A high performance web server and reverse proxy server.

    nginx -t
    

    nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
    nginx: configuration file /etc/nginx/nginx.conf test is successful

    thanks @ageorgiev

I have a question, should I create a directory
/etc/nginx/sites-available/domain1.com

for each site?
sorry for my bad english, im using translator. i speak portuguese.

I just followed the tutorial for the first site. ‘dietasbaratas.com’

now trying to enter http and https appears:

“Welcome to nginx!
If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

For online documentation and support please refer to nginx.org.
Commercial support is available at nginx.com.

Thank you for using nginx. ”

not opening the site yet. where is my blog, how do I get out of this nginx page?

Submit an Answer