Question

Help! Backup system didn't restored my apps back

Hi everyone,

I have a 2 year droplet running with 2 applications (with a separate droplet for mysql databases). The droplet runs the Debian operating system. This droplet was built by someone else.

Today, I tried to reset the password and after resetting I was able to log in, but the applications no longer run. I looked in /var/www/html/ but no content as it was empty.

I decided to revert it back using an older backup. Going to Backup, click More and Restore. I waited and, after the restoration was completed, I tried to load the applications again, but the same result “This site can’t be reached”.

I’m in a desperate situation, because I can’t make the applications run again at least in the last backup phase. Please help me.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @LittleGreenBlueRaft,

I urge you to take @JasonLABS’s advice and contact the person which developed your Droplet in the past.

If you can’t here are a little tips that can help you out to at least see which folder you’ll need to be looking to find your Applications.

First thing is to find if you are using Apache or Nginx:

nestat -tulpen | grep 443

There you should be able to see the WebService you are using. If you are using Nginx, go to

cd /etc/nginx/sites-enabled; ls

If it’s Apache:

cd /etc/apache2/sites-enabled; ls

See the content of the folder. There you should see the configuration files of your Applications. You can cat the files and see their DocumentRoot. In the DocumentRoot you should be able to find the applications.

Now for the error “This site can’t be reached”. Is there any chance your Domains expired? Try to ping them, see if they load from your Droplet or somewhere else.

Thank you for the help.

I found the files in a different location and there was no sites enabled in Apache. Therefore, I guess the configuration was totally different. I’m not familiar with the more complex server architecture, but it could be containers or something.

I decided to create a new droplet using a standard LAMP configuration with Ubuntu and PHP 7.4. Redirecting all subdomains using Network to new droplet. AllowOverride All to enable .htaccess in apache2.conf. Connecting to MySQL which is a different droplet.

Works perfect now. :)

Now, I expect that the MySQL droplet has the same configuration. If I will reboot/restore it will no longer work. I’m not sure why can’t manage to run when I’m trying to reset the root password or restore a backup.

First, the best thing to do would be to contact the one who built the droplet.

If that is not possible: It would help to have more clarification on what technology stack you are using.

  • I see you mention /var/www/html/, does this mean you are using apache2, Nginx, or other?
  • I see this question tagged with “Docker”, are these 2 Docker applications?
  • What password did you reset? root? user? other application?

If you’re using Docker for these applications you might want to look up how to check on the status of a Docker application.

It will be hard for someone to help without further info. Sorry you’re in a hard situation.