Question

Help getting SSL security installed on Ubuntu 16.04

Hi all, for 3-4 years I had a domain SSL-secured on my server running Ubuntu 14.04. Recently I wiped it and started with a fresh install of Ubuntu 16.04. If I use 000-default.conf and simply have it do HTTP on port 80 there are no problems; but when I try configuring default-ssl.conf with the SSL certificates I got from GoDaddy and my private key file, no joy whatsoever. I’ve talked to several IT experts about my problem, but no one seems to be able to help me out. Anyone ever have a similar problem in 16.04. Nothing very exciting in terms of error logs. At least not that I can see. Again, we are talking about a system that worked fine in 14.04 with SSL; only when I moved in a fresh install to 16.04 did it stop working. Yes, I chose a2ensite, did a2enmod SSL, restarted apache2, am sure port 443 is opened in UFW, etc. But no go. Anyone been here and done this?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey @legrandtimonier1951 . I am experiencing the same issue. Been searching for a solution for days without success. Were you able to resolve your issue, if so i would really appreciate it if you share your solution.

hi. no, it never worked. and i did exactly what i’d done in version 14.04 of Ubuntu, which had only 1 IP address, by the way. But it used to work just fine, before trying the same trick with Ubuntu 16.04. So I had to give up in the end. Are you trying to do the same thing? Have you succeeded in doing the same thing with Ubuntu 16.04?

@legrandtimonier1951 so it worked when you reinsall apache !! ?