Question

[Help Needed] MongoDB Error!

Greetings Everyone!

So today I actually encountered an error while setting up my nodebb system. The problem was with mongodb! When I started the system using sudo systemctl start mongodb it shows an message as Faild to start mongodb.service: Unit mongodb service is not loaded properly: Bad Message.

And when using commands sudo systemctl status mongodb ill post the error logs as an image and it is into two parts as an image below

http://i.imgur.com/U77wTVz.jpg


http://i.imgur.com/DlJQdwk.jpg


I need help with this my system is on Ubuntu 16.04.2!


Thanks to those who help! Kind Regards, /shar

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

What does your error log say? Please don’t post pictures, just post the error log contained in code-tags. When I do a search for “mongodb status 217” it mostly has something to do with username containing dashes. Does your configuration has a username with a dash?

This comment has been deleted