[Help Needed] MongoDB Error!

March 26, 2017 1.8k views
MongoDB DigitalOcean Ubuntu 16.04

Greetings Everyone!

So today I actually encountered an error while setting up my nodebb system. The problem was with mongodb! When I started the system using sudo systemctl start mongodb it shows an message as *Faild to start mongodb.service: Unit mongodb service is not loaded properly: Bad Message*.

And when using commands sudo systemctl status mongodb ill post the error logs as an image and it is into two parts as an image below

http://i.imgur.com/U77wTVz.jpg


http://i.imgur.com/DlJQdwk.jpg


I need help with this my system is on Ubuntu 16.04.2!


Thanks to those who help!
Kind Regards,
/shar

1 comment
2 Answers

What does your error log say? Please don't post pictures, just post the error log contained in code-tags.
When I do a search for "mongodb status 217" it mostly has something to do with username containing dashes. Does your configuration has a username with a dash?

  • [Unit]
    Description=High-performance, schema-free document-oriented database
    After=network.target
    Documentation=https://docs.mongodb.org/manual

    [Service]
    User=mongodb
    Group=mongodb
    ExecStart=/usr/bin/mongod --quiet --config /etc/mongod.conf

    [Install]
    WantedBy=multi-user.target

    I used this as the /etc/systemd/system/mongodb.service is it the Service->ExecStart problem as I have an /usr in front of it or should it just start with use??

Have another answer? Share your knowledge.