Question

Help - Server wont boot after migration!

Hi - I’m getting an error on my ubuntu server after it was migrated during the digital ocean maintenance window. The console says

RAMDISK: gzip image found at block 0 RAMDISK: incomplete write (4871 != 24070) write error VFS: cannot open root device “LABEL=DOROOT” or unknown-block(0,0) Please append a correct “root=” boot option; here are the available partitions: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

and then the stack trace below that.

Any ideas? I"m desperate?

R

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Fixed it myself - the kernel ramdisk had become corrupted in the transfer. Halted the machine, installed a new kernel via the control panel, and boot the machine. Console came up but no networking. Module deps weren’t available for the kernel I’d selected - powered off and switched to an older kernel that I knew I had modules for, reboot, and now the vm is fine and networking came up correctly.

Oh god i had same problem, are u problem solve? i have much data on here, i have problem kernel panic - not syncing: vfs Unable to mount root fs on unknown-block (0,0)

Hi Woet - I’ve done that - still waiting… :-s

Open a ticket.