High Latency every 12 hours

July 12, 2014 1k views

Anyone seeing high latency on your droplet ? Ours happens every 12 hours after reboot and our server is iptabled to only 1 external IP.

All we have been told is that powering off the droplet is different than rebooting it (resets some kind of network interface structure), but that only last 12 hours, then Latency can hit 400ms average until another power down and boot.

We have a droplet which we have destroyed and recreated (to eliminate physical hypervisor).

It only talks to 1 IP for monitoring.

The code is running on another VPS provider with outside connections and its working fine.

Our issue is that out of 80+ droplets, this is our newest one and every 12 hour the latency goes nuts.

We asked digital for a call , but nothing. I'm sure our revenue is nothing for them, so you get what you pay for...

2 Answers

I have occasionally seen latency problems while working on my droplets in the NYC2 data center. It has always resolved without a reboot, though.

We have 80+ droplets, this is the newest one, so we think it might have something to do with a new Kernel.

  • New Droplet from an image we use for many other working droplets
  • Backed up from an off-line backup
  • Wait 12 hours and you see HIGH latency:

MTR (without showing too much information)
Packet loss 0.4%

Packet #2998

Average 1675

The catch is that all software is the same on another virtual and is running without incident.

Have another answer? Share your knowledge.