Question

Hosting website on DO but using shared hosting mail servers

I recently migrated my site from a shared hosting account on StableHost.com over to DO.

The file migration went smoothly (mostly), however, I have a question about the mail. With Stablehost, I managed everything through cpanel and configured my incoming and outgoing mail servers with Gmail based on the configuration info obtained from cpanel.

However, now that I’ve change my dns information to point to digitalocean servers, I’ve stopped receiving emails. I’m assuming there is something wrong that I have to change with the MX entries (on DO or on StableHost?)

Is it possible for me to keep using my old shared stablehost account just for the mail services (avoiding setting up my own mail servers on DO)? How do I configure this to fix my email?

Thank you! Niket

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

If you post your domain name, I can figure this out for you and give you exact steps. Let me a question.

Originally you had your NS records defined in your stable host account and pointing to their DNS servers, then when you started up this droplet, in the Hover.com account, you updated your name servers to point to digital ocean, correct?

Email was working as expected prior to this change, correct?

If this is accurate then you need to create MX records on your digital ocean host. Not sure if there is a control panel of if you will need to edit /etc/named.conf

Add two MX records pointing to aspmx.l.google.com. alt1.aspmx.l.google.com.

Leave the name portion blank and make one of them a 0 priority and one a 10

My guess is right now that if you pull up a command prompt on windows and do a nslookup

then set type=mx Then your domain name and enter.

You will get a blank record as your MX records are defined on your old DNS and not present on your current DNS.

Post your domain name and the ip of one of your old DNS servers and I’ll give you exact steps for what you need to do.