Caglayan
By:
Caglayan

How Can i add Let's Encrypt SSL Certificate to all my blog pages and articles?

July 31, 2017 294 views
Let's Encrypt Ubuntu 16.04

Hello everyone,
i just set up a wordpress blog website and using Let's Encrypt SSL for my domain like www.ankarafizyoterapistim.com and ankarafizyoterapistim.com and i have no problem.
But when i set up a blog page like ankarafizyoterapistim.com/blog or a article page like ankarafizyoterapistim.com/article SLL doesn't work. So how can i add SSL for my blog page and my articles. i'm gonna write an article everyday.is there any solution for my problem?
thx for everyone.

i set up my SLL just like mentioned in this
(Sorry for bad english)

1 comment
  • Where are you configuring it currently? The easiest solution for something like this would be to put nginx in front of it and let it handle the TLS, rather than messing around in any individual applications. Assuming nginx and the application it's proxying are on the same physical machine, this is the simplest solution and has no negative implications that I'm aware of.

4 Answers

Hi @Caglayan,

How did you set it up exactly? Did you allowed both HTTPS and HTTP traffic? If yes, you should setup redirection from HTTP to HTTPS and that should do the job. You could also change all your links in WordPress to point form http://example.com/blog to https://example.com/blog.

hi @SporkWitch @xMudrii

Firstly,
i only set up my ssl certificate to my main domain (ankarafizyoterapistim.com and www.ankarafizyoterapistim.com)
i didn't set up ssl certificates for my (www.ankarafizyoterapistim.com/blog and ankarafizyoterapistim.com/blog page.)
when i set up i select ''force all http to https'' option.
i changed my post links in wordpress options like ankarafizyoterapistim.com/blog/%postname%/
and i dont know nginx thing .
i only set my wordpress with one click application then i used these codes.
1-sudo add-apt-repository ppa:certbot/certbot
2-sudo apt-get update
3-sudo certbot --apache -d example.com -d www.example.com
4-https://www.ssllabs.com/ssltest/analyze.html?d=example.com&latest( i tested )
4-sudo crontab -e
5-15 3 * * * /usr/bin/certbot renew --quiet

i'm so newbie for digitalocean,ip,root things:)
if you can please teach me
thx for everything ...
(sorry for bad english)

do i need to take certificates for my blog page too?

  • Hi @Caglayan

    Your Let's Encrypt certificates are for your entire domain - also any path within your domain.

    But it seems like you have setup a logo or something on /blog/ when the site was HTTP, which is why you get mixed content warnings on HTTPS.
    Change the media links, so it's HTTPS, then you won't have the mixed content warnings.

@hansen i changed my logo link http to https and it works:)
ty so much for your help
@SporkWitch @xMudrii @hansen

Have another answer? Share your knowledge.