Question

How can I disable IPv6 on Digital ocean droplet?

  • Posted July 2, 2017
  • IPv6

I followed the directions in the tutorial “How To Enable IPv6 for DigitalOcean Droplets”. I’ve decided not to use IPv6 with this droplet and would like to disable it.

Subscribe
Share

HELL YEAH, thanks a lot for this thread! Spent lots of time telnet-ing, dig-ing etc. For anyone with this kind of problems - DO NOT USE digitalocean’s IPv6 if you need SMTP in some way. With it enabled your connections will struggle huge speed loss when trying to do telnet smtp.gmail.com 465 openssl s_client -host smtp.yandex.ru -port 465 And your Swiftmailer (or what you use) will fail with timeout exception. If that looks familiar - use @hansen proposed solution


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @digitalocean718

Since you haven’t noted what OS you’re using, so I’m guessing it’s Ubuntu/Debian. Go and edit this file /etc/network/interfaces. And remove the IPv6 section that looks similar to this and then reboot the server:

iface eth0 inet6 static
        address primary_ipv6_address
        netmask 64
        gateway ipv6_gateway
        autoconf 0
        dns-nameservers 2001:4860:4860::8844 2001:4860:4860::8888 209.244.0.3

It’s not possible to remove the “IPv6” nor “Private Networking” from the droplet via the control panel after it’s been activated. But by removing the configuration, we actually disable the functionality completely.

Why would you want to?

The easiesed way I found how to do this is to shut down your droplet, take a snapshot of it and create a new droplet from the snapshot. In the creation process, don’t select the IPv6 option. DO agent will also take care of unconfiguring the old IPv6 address in the OS since it has to touch the network config anyways to configure the new private IP.

Obviously you want a floating IP to avoid any disruptions for this.

having same issue.

Hello everybody.

Somebody make this works? I have the same issue with a FreeBSD droplet. I have an option to disable ipv6 on my /etc/rc.conf but every time a disable this configuration when droplet boot again its being replaced again for DO auto-script.

It’s a mess

My Os is Centos7, but cant find the iface eth0 inet6 static address primary_ipv6_address netmask 64 gateway ipv6_gateway autoconf 0 dns-nameservers 2001:4860:4860::8844 2001:4860:4860::8888 209.244.0.3

on the interfaces.

Is the reboot necessary after updating those IPv6 settings? I have issues with IPv6 and some third party server monitoring software and it is on my production database server. I can’t afford to have that server down and setting up a hot-swap or standby server will be time consuming for my very limited needs.