Question

How can I enable htacess Centos apache?

Posted May 10, 2020 285 views
CentOSApache

I can’t run .htaccess files on my website. How can I enable it? I am using Centos 7 with apache.

I tried editing /etc/httpd/conf/httpd.conf and added

<VirtualHost *:80>
ServerName example.com

# Disable .htaccess for /var/www directory for security
<Directory “/var/www”>
Allowoverride none
</Directory>

# Enable .htaccess for /var/www/html directory and its subdirectories
<Directory “/var/www/html”>
Allowoverride all
</Directory>
</VirtualHost>

But it doesn’t work..

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Okay I find it…
Open /etc/httpd/conf/httpd.conf
and search this: AllowOverride controls what
And edit AllowOverride to All

Hi @dtorgul,

Don’t worry my dude, Use the following configuration in your Apache Virtual host configuration file.

<VirtualHost *:80>
  # Admin email, Server Name (domain name), and any aliases
  ServerAdmin webmaster@example.com
  ServerName  example.com
  ServerAlias www.example.com

  # Index file and Document Root (where the public files are located)
  DirectoryIndex index.html index.php
  DocumentRoot /var/www/html/example.com/public_html
  <Directory /var/www/html/example.com/public_html>
      Options Indexes FollowSymLinks
      AllowOverride All
      Require all granted
  </Directory>

  # Log file locations
  LogLevel warn
  ErrorLog  /var/www/html/example.com/log/error.log
  CustomLog /var/www/html/example.com/log/access.log combined
</VirtualHost>

Please specify the exact location of website root directory (/var/www/html/example.com/public_html) in the configuration.

Submit an Answer