Question

How can i fix this fastcgi errors?

  • Posted on December 29, 2014
  • tokar93Asked by tokar93

Hi

I get this error in my error log:

[Mon Dec 29 04:35:09.016736 2014] [fastcgi:error] [pid 21815] [client 178.62.80.152:32655] FastCGI: incomplete headers (0 bytes) received from server “/var/www/clients/client0/web4/cgi-bin/php5-fcgi--80-myabdllife.com" [Mon Dec 29 04:35:10.063692 2014] [fastcgi:error] [pid 21814] [client 178.62.80.152:35281] FastCGI: comm with server "/var/www/clients/client0/web4/cgi-bin/php5-fcgi--80-myabdllife.com” aborted: idle timeout (300 sec)

What can i do about it to get it fix?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This error is usually the result of an improperly written CGI script that, as the error suggests, is not sending the proper headers. I ran into this error from my own CGI scripts until I added a “Content-type: text/html” header followed by a blank line before returning anything else. This assumes, of course, that what you’re returning is actually text/html. You may wish to do some further research on this topic to ensure that your script is correctly written for whatever it is you’re trying to do with it.