Posted March 20, 2013 178.6k views
Please someone with a solution for me. I just made a droplet from my work and now @ my home i can't access anymore and get this message :s @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY! Someone could be eavesdropping on you right now (man-in-the-middle attack)! It is also possible that a host key has just been changed. The fingerprint for the RSA key sent by the remote host is
  • @kamaln7 champion! its worked. after I deleted my old fingerprint and trying again root@ipaddress with new password from email and create on own prefer password.

  • I’ve been having this problem with a single droplet that has had SSL certificates installed. I have 20 other droplets that do not suffer from this problem. It seems that every time that I am on a different internet connection, which is very frequent in my travels, the server has a different host key. Clearing the lines from my known_hosts file does suppress the warning until the next time that I try to connect from a different IP address. Anybody have any ideas?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
8 answers
You can just delete the line that have your current IP in the known_hosts file.
Sorry, my reply stripped out some text...

ssh-keygen -R [HOSTNAME]
ssh-keygen -R [IP_ADDRESS]

Alternatively, if you only SSH to a small set of known hosts, you can just delete your [HOME]/.ssh/known_hosts
  • This one worked for me! My installation was running fine, but I moved it into a VPC and something changed. Anyway, running ssh-keygen -R or ssh-keygen -R fixed it.

    Just to be clear: You run the above command on the machine you are logging in from.

    Thank you :)

This is happening because the ID for your hostname is not what your client expected. This can happen if you rebuilt your droplet from scratch, or if you recently pointed your hostname to a different server. The fix depends on your client.

If you're running a relatively common Linux distribution, you can usually run the following:
ssh-keygen -R
... OR/AND ...
ssh-keygen -R

Which will clear the corresponding entries in your .ssh/known_hosts file.

I don’t understand…

Thank you all, fixed!!!

Issue fixed..Thanks a lot