Question

How can I increase the max upload file size on a one-click Owncloud droplet?

Posted July 27, 2015 6.6k views
UbuntuDigitalOcean 1-Click Apps Marketplace

I’ve checked the loaded php.ini and increased upload and post sizes, restarted apache2 but Owncloud still reports 512M max upload size.

2 comments

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

This is the answer:

From the admin_manual:
https://doc.owncloud.org/server/7.0/adminmanual/configuration/bigfileuploadconfiguration.html

OwnCloud comes with its own owncloud/.htaccess file. Set the following two parameters inside this .htaccess file:

php_value upload_max_filesize = 16G
php_value post_max_size = 16G

Change this values in the .htaccess and restart apache2 again.

mentionable:
In the php.ini you should also increase:

 max_file_uploads 
 max_execution_time 


Hello,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of uploadmaxfilesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 200M

You also need to restart your web server in order the changes to take effect.

Hope that this helps!
Regards,
Alex