salopez
By:
salopez

How can I redirect to www.domain.com/forum

November 4, 2016 121 views
Networking Ubuntu 16.04

Hi there,

I am trying to redirect the URL when I write www.domain.com to www.domain.com/forums.
I already tried with a couple of htaccess files, but with no results. For example:
RewriteCond %{HTTP_HOST} ^domain.com
RewriteRule (.*) http://www.domain.com/forums [R=301,L]

Hope you can help me.

Regards.

1 Answer

This should do the trick inside your VirtualHost:

Redirect permanent / https://www.domain.com/forums/
  • Should I put that inside the htaccess file?

    • No, this can go directly into your virtualhost configuration in /etc/apache2/sites-enabled

      • http://www.domain.com/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/forums/
        

        It seems it enters in a loop and fails. Below you will find my config:

        <VirtualHost *:80>
            # The ServerName directive sets the request scheme, hostname and port that
            # the server uses to identify itself. This is used when creating
            # redirection URLs. In the context of virtual hosts, the ServerName
            # specifies what hostname must appear in the request's Host: header to
            # match this virtual host. For the default virtual host (this file) this
            # value is not decisive as it is used as a last resort host regardless.
            # However, you must set it for any further virtual host explicitly.
            #ServerName www.example.com
        
            ServerAdmin webmaster@localhost
            DocumentRoot /var/www
                Redirect permanent / http://www.domain.com/forum
            # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
            # error, crit, alert, emerg.
            # It is also possible to configure the loglevel for particular
            # modules, e.g.
            #LogLevel info ssl:warn
        
            ErrorLog ${APACHE_LOG_DIR}/error.log
            CustomLog ${APACHE_LOG_DIR}/access.log combined
        
            # For most configuration files from conf-available/, which are
            # enabled or disabled at a global level, it is possible to
            # include a line for only one particular virtual host. For example the
            # following line enables the CGI configuration for this host only
            # after it has been globally disabled with "a2disconf".
            #Include conf-available/serve-cgi-bin.conf
        </VirtualHost>
        
        # vim: syntax=apache ts=4 sw=4 sts=4 sr noet
        
        
        • Make sure you have removed the .htaccess file you have with the rewrite rule. My best guess is that both the redirect in the configuration file and the rewrite redirect are causing the loop as one redirects to the other, etc.

Have another answer? Share your knowledge.