Question

How do I access the redis server from my loca machine?

I have already setup inboud rule to accept port 6379 when I try to connect to the redis server from my local machine using the public ip, I get an error " No connection could be made because the target machine actively refused it"

how could I enable redis to be accessible from outside ? Thanks -Shathish


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Have you enabled bind option in conf file to listen on all interfaces, or public interfaces? Have you restarted the redis service? Are you sure it’s not enabled under unixsocket instead?

Finally check the connection locally, if it works, try using telnet to test the TCP connectivity (not redis itself)

telnet SERVER 6379