Question

How do I change phpMyAdmin access url?

  • Posted January 7, 2015

I’m trying to change the default access url for phpMyAdmin from /phpmyadmin to something less common.

After googling, the only file I was able to find and edit was /etc/phpmyadmin/apache.conf - I changed the default aliases there, but after restarting apache it didn’t seem to make a difference. I was still able to access it via /phpmyadmin and my new alias didn’t work.

Some other sites say I have to edit httpd.conf or https-alias.conf - but I can’t find those files, and there is no alias list in 000-default.conf

Subscribe
Share

/etc/apache2/conf-available/phpmyadmin.conf

line 3:

Alias /whateveryouwant /usr/share/phpmyadmin

/etc/apache2/conf-available/phpmyadmin.conf

line 3:

Alias /whateveryouwant /usr/share/phpmyadmin

In my case (Ubuntu 14.04.1 LTS) it was located on /etc/phpmyadmin/apache.conf

I found the phpmyadmin configuartion file. it is located here:

/etc/apache2/conf-enabled/phpmyadmin.conf

@sierracircle that file doesn’t exist… I’m using Ubuntu 14.04


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

You need to add apache2 config : sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf sudo a2enconf phpmyadmin.conf sudo service apache2 reload

I set it based on @mhardaniel tutorial, but I got this below error message in apache log:

[Mon Jan 21 06:25:03.272652 2019] [alias:warn] [pid 763:tid 140451442693312] AH00671: The Alias directive in /etc/phpmyadmin/apache.conf at line 4 will probably never match because it overlaps an earlier Alias.

How can I fix this?

Thanks!

This comment has been deleted