How do i clear the error which i get on executing "docker-compose up -d"

October 18, 2019 1.9k views
Docker Ubuntu 18.04 Applications Python Frameworks Nginx

HI i am new to the docker and flask applications and i was working on a project where i was using Flask framework +mongoDb database in a docker and i found a helpful tutorial :
Example link

and followed line by line but when i execute
“docker-compose up -d”
i am getting error:

Building webserver
Step 1/6 : FROM digitalocean.com/alpine:latest
ERROR: Service 'webserver' failed to build: error parsing HTTP 404 response body: invalid character '<' looking for beginning of value: "<!doctype html>\n<html\n  class=\"\"\n  lang=\"en\"\n>\n  <head>\n    <meta charset=\"utf-8\">\n<meta http-equiv=\"x-ua-compatible\" content=\"ie=edge\">\n<title>404 Error</title>\n<meta name=\"description\" content=\"\">\n<meta name=\"viewport\" content=\"width=device-width, initial-scale=1\">\n\n<meta property=\"og:url\" content=\"https://www.digitalocean.com/404/\">\n<meta property=\"og:title\" content=\"404 Error\">\n<meta property=\"og:description\" content=\"\">\n<meta property=\"og:site_name\" content=\"DigitalOcean\">\n<meta property=\"og:image\" content=\"https://www.digitalocean.com/assets/media/logo-a721c4a7.png\">\..........

I searched whole web but could not get the exact solution
hope someone will help me out.

my docker info:

Client:
 Debug Mode: false

Server:
 Containers: 0
  Running: 0
  Paused: 0
  Stopped: 0
 Images: 13
 Server Version: 19.03.3
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: true
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
 Plugins:
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: b34a5c8af56e510852c35414db4c1f4fa6172339
 runc version: 3e425f80a8c931f88e6d94a8c831b9d5aa481657
 init version: fec3683
 Security Options:
  apparmor
  seccomp
   Profile: default
 Kernel Version: 4.15.0-58-generic
 Operating System: Ubuntu 18.04.3 LTS
 OSType: linux
 Architecture: x86_64
 CPUs: 1
 Total Memory: 985.5MiB
 Name: dockerFlask
 ID: UGNF:AT52:QHK4:KWS4:G6DO:YYFH:HRCF:K7AN:D46R:PG75:NHT7:RGKN
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Registry: https://index.docker.io/v1/
 Labels:
 Experimental: false
 Insecure Registries:
  127.0.0.0/8
 Live Restore Enabled: false

WARNING: No swap limit support
2 Answers

I am following the same tutorial and having the same issue. Please help!

The tutorial Client:
Debug Mode: false

Server:
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 13
Server Version: 19.03.4
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host ipvlan macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: b34a5c8af56e510852c35414db4c1f4fa6172339
runc version: 3e425f80a8c931f88e6d94a8c831b9d5aa481657
init version: fec3683
Security Options:
apparmor
seccomp
Profile: default
Kernel Version: 4.15.0-65-generic
Operating System: Ubuntu 18.04.3 LTS
OSType: linux
Live Restore Enabled: false

WARNING: No swap limit support

try using a different image . I switched it to

FROM alpine:latest

Have another answer? Share your knowledge.