Question

How do I configure remote admin in glassfish 4.1 server?

Posted November 14, 2015 10.4k views
Linux Basics Getting Started

Centos 7.1
Glassfish Server 4.1
Java 8
Hi, i installed glassfish server 4.1 in centos 7.1 . The installation was ready but “Secure Admin must be enabled to access the DAS remotely”.
I can´t apply command asadmin change-password-admin, the console shows:

Traceback (most recent call last):
File “/usr/bin/asadmin”, line 260, in <module>
autoscale = boto.connectautoscale()
File “/usr/lib/python2.7/site-packages/boto/
init.py”, line 202, in connectautoscale
**kwargs)
File “/usr/lib/python2.7/site-packages/boto/ec2/autoscale/init.py”, line 110, in init
profilename=profilename)
File “/usr/lib/python2.7/site-packages/boto/connection.py”, line 1057, in init
profilename=profilename)
File “/usr/lib/python2.7/site-packages/boto/connection.py”, line 568, in init
host, config, self.provider, self.requiredauthcapability())
File “/usr/lib/python2.7/site-packages/boto/auth.py”, line 882, in get
auth_handler
‘Check your credentials’ % (len(names), str(names)))
boto.exception.NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler’] Check your credentials

any Help?

Thanks!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

1 answer

@jlbugarin

You’ll need to run

asadmin --host [host] --port [port] enable-secure-admin

[host] = Droplet’s Public IP - or - Server Hostname (i.e. name.domain.ext).

[port] = The Port you wish to use when accessing.

Once executed, you’ll need to restart Glassfish Server for the changes to take effect.

Submit an Answer