Question

How do I connect dreamweaver to my public_html folder?

I sort of installed the LAMP server pretty quickly and then installed ProFTPD on Ubuntu 12.04.

But I cant actually ftp. I can connect to my usernam or my root but not to the public_html.

This is probably really simple but as i cant solve it its an impassable barrier.

I can fire up MySQL and can see the Apache page. It all seems to run ok but I just cant upload files to the public_html part.

I have read other questions and none of them help.

I can log in from FileZilla and then move up the directory structure to /var/www/html but I cant do it in Dreamweaver as I canr log into public_html

Subscribe
Share

This might help:

<VirtualHost *:80> # The ServerName directive sets the request scheme, hostname and port that # the server uses to identify itself. This is used when creating # redirection URLs. In the context of virtual hosts, the ServerName # specifies what hostname must appear in the request’s Host: header to # match this virtual host. For the default virtual host (this file) this # value is not decisive as it is used as a last resort host regardless. # However, you must set it for any further virtual host explicitly. #ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf

</VirtualHost>


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

DW old staff

I do believe this was me!!!

‘manually set the remote path’ indeed.

That doesnt work at all.

On DW you can manually set the remote path to /var/www/html/ this is in site configuration remote options inside DW options