How do I connect my droplet to my domain?

May 19, 2014 2.7k views
I know this should be a no-brainer but I need a little help. I have the domain (registered through godaddy) and I've changed the nameservers to digital ocean's (DS1.DIGITALOCEAN.COM, ... etc) but my site can't be found in browsers and I can't access the digital ocean server with my username and password (root / ********) with my ftp (FileZilla) What am I to do? I have a droplet ( with a ip address Also I got a zone file that looks like this $TTL 1800 @ IN SOA NS1.DIGITALOCEAN.COM. ( 1400455440 ; last update: 2014-05-18 23:24:00 UTC 3600 ; refresh 900 ; retry 1209600 ; expire 1800 ; ttl ) IN NS NS1.DIGITALOCEAN.COM. NS NS2.DIGITALOCEAN.COM. NS NS3.DIGITALOCEAN.COM. @ IN A How to I make it so I can access with a browser and ftp
3 Answers
You need to add an A record for your domain that points to the droplet IP and then install a webserver on the droplet and configure the vhost.

by Etel Sverdlov
This article walks you through setting up the DNS for your site. The tutorial includes steps to set up an A records, point your nameservers, and provides some information about MX records.
Hey thanks for being very patient with me. I really appreciate it

I have an A record of @ set up

Digital Ocean says I have an image of Ubuntu 14.04 x64 running on the droplet.

I've tried doing whois queries on and it doesn't give me an IP

Unfortunately its still not working.

As far as I know it seems like everything should be set up but there's a disconnect between the domain name and the digital servers (I double checked the nameservers and their pointing to digital ocean).
Hey Chris,

I can ping your domain and get the right IP. So I don't think the issue is with DNS:

root@trusty-test:~# ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=53 time=81.9 ms

Running nmap show that the only open port is 22. Do you have a firewall set up? Port 80 isn't open.
Have another answer? Share your knowledge.