Hello,

I’m coming from AWS, so I’m getting pretty frustrated at how difficult it seems to be to just ssh into the managed database.

I don’t see any tutorials on how to ssh into the managed database or how to connect it to MySql workbench. What I do see is that almost every tutorial for remote connection says that I need to update to Mysql 8.

I don’t understand why I have to do this? The servers that are pulling from the managed database server shouldn’t have to be running the same version of Mysql as the managed database server. Am I missing something here?

I know I’m ranting, so I’ll narrow down my focus… What I’d just like to figure out is to how to connect to the database via Mysql Workbench - preferably without having to upgrade to Mysql 8.

DO provides this (public):
username = doadmin
password = [password]
host = [host]
port = 25060
database = defaultdb
sslmode = REQUIRED

And the ca cert.

I enter this in Mysql Workbench:
SSH Hostname = [host]
SSH Username = doadmin
SSH Password [password]

MySQL hostname = 127.0.0.1
Mysql Server Port = 3306
Username = root
password =??
CA-Cert = [path to ca cert]

I’ve tried various configurations, but the closest I get is with the error:
Authentication error. Please check that your username and password are correct and try again.
Details (Original exception message):
Bad authentication type, the server is not accepting this type of authentication.
Allowed ones are:
[u'publickey’]

Any help would be greatly appreciated.

1 comment
  • Hi Guys,
    I am trying to connect to MySQL managed DB, but unable to connect. I love the documentation on Digital Ocean, it has always helped me to get things done quickly in a nice way, but when it comes to connecting managed db, I do not see any proper documentation that works.
    I am trying to connect via Sequel Pro. I have no idea how to use the CA Certificate that I download.

    Please help me get past this.

    Thanks,
    Altaf

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hi @aflores, the managed database servers do not come with SSH access as this is the point of the servers being managed, you just use them as MySQL servers and connect via MySQL only.

You can follow the official step by step instructions on how to connect to the managed MySQL servers here:

https://www.digitalocean.com/community/tutorials/how-to-connect-to-managed-database-ubuntu-18-04#connecting-to-a-managed-mysql-database

by Mark Drake
If you're new to working with managed databases, the best way to perform certain tasks, like connecting to the database, may not be self-evident. In this guide, we will go over how to install client programs for a variety of database management systems, including PostgreSQL, MySQL, and Redis, on an Ubuntu 18.04 server. We'll also explain how to use these programs to connect to a managed database instance.
  • So I can’t connect to the managed database via MySql workbench or Sql pro?

    • You should be able to, as long as you use the correct details like the port, the host, the user and the password. Also make sure to allow your IP in the trusted hosts for the database.

      • So is that something you can provide more information about? Since it doesn’t use SSH, I’m trying to connect via “Standard (TCP/IP)”

        Parameters:
        Hostname: [do host]
        Port: 2506
        Username: doadmin
        password: [do provided password]

        SSL:
        Use SSL: Require
        SSL CA File: [path to do provided ca cert]

        With this I’m getting the error “SSL connection error: unknown error number”

        Now my local machine is running on Mysql version 5.7, but I don’t see why this would matter.

I had this exact issue, and upgrading MySQL Workbench to 8+ worked as expected. Basic connection and I am good to go.

Submit an Answer