Question

How do I enable PHP on my Ubuntu server?

  • Posted March 3, 2014

HI everyone,

I recently tried setting up iRedMail on my Ubuntu server, but decided to go with another mail service after realizing how hard it was to actually set it up. In the end, my www directory was moved to /usr/share/nginx/www when before it was in /var/www. Since then my contact.php form does not pull up on my server as an actual page, but rather a download link. I have tried to reconfigure apache and re install any php modules, but even then when I try to do so, i get "E unable to find ‘module example’.

What do I need to do to enable php support on my server again? The default index.php files that we create in the tutorial doesn’t show up like it did when I first set up my server…

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Do you want to use nginx or apache? It seems like you’re trying to use apache but have nginx installed instead. Check out <a href=“https://www.digitalocean.com/community/articles/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu”>https://www.digitalocean.com/community/articles/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu</a>, make sure you remove nginx before following that article.