Question

How do I enable the SoapClient class after installing it?

Posted September 26, 2016 13.7k views
WordPressUbuntu 16.04

When viewing the System Status of WooCommerce on my WordPress install, I noticed this message: “SoapClient: Your server does not have the SoapClient class enabled - some gateway plugins which use SOAP may not work as expected.”

So I went ahead and figured out how to install the SoapClient here: Does Digitalocean support SOAP class?

After installing it, I refreshed the System Status page and the message was the same.

Is there a way to enable this? I feel like that step still needs to be completed, just not sure how.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
4 answers

I believe my issue may have been Cache related. Recently checking the System Settings page of WooCommerce and it shows that this is ok now.

Make sure to restart your server after installing the SoapClient with:

sudo systemctl restart apache2

Had the same issue. Did a yum --enablerepo=ius-archive install php71u-soap. Extension got installed as I saw:

[root@Unixserver modules]# php -m | grep -i soap
soap

Still got the warning in WooCommerce. Even after I restarted Nginx using service nginx restart

Then I /etc/init.d/php-fpm restart and that did the trick

So I was looking for a solution to this problem

SoapClient: Your server does not have the SoapClient class enabled - some gateway plugins which use SOAP may not work as expected.

I did all the suggestions didn’t work:

Edit the main PHP configuration file /etc/php.ini and enable the SOAP extension by uncommenting the line:
extension=/usr/lib/php/modules/soap.so
I even uncommented every line with soap in it

Restarted Php-FPM and Ngnix several times

Did apt-get install php-soap which gave me an error that it couldn't fetch the file.
Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/p/php7.2/php7.2-soap_7.2.24-0ubuntu0.18.04.1_amd64.deb 404 Not Found

Couldn’t figure out what was the issue. Then I spotted this in the terminal

Unable to fetch some archives, maybe run apt-get update or try with –fix-missing?

So the solution was:

Simply run apt-get update and apt-get upgrade on your VPS machine

After that apt-get install php-soap

Restart your Nginx and Php-fpm

Check Woocommerce Status. Happy days!
Submit an Answer