Question

How do I enable zswap on ubuntu?

Hi,

How can I enable zswap on a ubuntu 14.04 instance? I did some searching and did this:

  1. I modified /etc/default/grub and changed GRUB_CMDLINE_LINUX_DEFAULT to GRUB_CMDLINE_LINUX_DEFAULT="zswap.enabled=1
  2. I then rebooted the system with “reboot”

I then tried to verify the presence of zswap by running “dmesg | grep zcache” but I couldn’t find anything. How do I know if I actually configured it properly and if it’s running?

Thanks!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

GRUB_CMDLINE_LINUX_DEFAULT=“zswap.enabled=1” is not where you enable it. You need to enable it here… GRUB_CMDLINE_LINUX=“zswap.enabled=1” Then run sudo update-grub and then reboot.

After modifying the grub files in /etc, you must run:

sudo update-grub