alexhoug
By:
alexhoug

How do I fix 404s after enabling http/2?

March 5, 2016 1.1k views
Apache PHP Ubuntu

Hello, I am running into issues with 404s after I enabled http/2 using this guide. My server is a LAMP droplet. Thanks for your help!

2 comments
  • Please post your Apache vhost config file.

  • I fixed the 404 by reverting what I did in step 3.

    Here is my apache vhost config:

    <VirtualHost *:443>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
    
        ServerName houg.co
    
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
    
        SSLEngine on
        SSLCertificateFile /etc/ssl/houg.co.crt
        SSLCertificateKeyFile /etc/ssl/houg.co.key
        SSLCertificateChainFile /etc/ssl/COMODORSAExtendedValidationSecureServerCA.crt
    
        #ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/var/www/html/$1
    
        # for a https server
        Protocols h2 http/1.1
    
        # for a http server
        #Protocols h2c http/1.1
    
        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn
    
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
    
        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
    </VirtualHost>
    
    <VirtualHost *:80>
       ServerName houg.co
       Redirect permanent / https://houg.co/
    </VirtualHost>
    
    # vim: syntax=apache ts=4 sw=4 sts=4 sr noet
    
2 Answers

This question was answered by @alexhoug:

I fixed the 404 by reverting what I did in step 3.

Here is my apache vhost config:

<VirtualHost *:443>
  # The ServerName directive sets the request scheme, hostname and port that
  # the server uses to identify itself. This is used when creating
  # redirection URLs. In the context of virtual hosts, the ServerName
  # specifies what hostname must appear in the request's Host: header to
  # match this virtual host. For the default virtual host (this file) this
  # value is not decisive as it is used as a last resort host regardless.
  # However, you must set it for any further virtual host explicitly.

  ServerName houg.co

  ServerAdmin webmaster@localhost
  DocumentRoot /var/www/html

  SSLEngine on
  SSLCertificateFile /etc/ssl/houg.co.crt
  SSLCertificateKeyFile /etc/ssl/houg.co.key
  SSLCertificateChainFile /etc/ssl/COMODORSAExtendedValidationSecureServerCA.crt

  #ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/var/www/html/$1

  # for a https server
  Protocols h2 http/1.1

  # for a http server
  #Protocols h2c http/1.1

  # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
  # error, crit, alert, emerg.
  # It is also possible to configure the loglevel for particular
  # modules, e.g.
  #LogLevel info ssl:warn

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

  # For most configuration files from conf-available/, which are
  # enabled or disabled at a global level, it is possible to
  # include a line for only one particular virtual host. For example the
  # following line enables the CGI configuration for this host only
  # after it has been globally disabled with "a2disconf".
  #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

<VirtualHost *:80>
  ServerName houg.co
  Redirect permanent / https://houg.co/
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

View the original comment

How to fix it? Both look almost similar.

Have another answer? Share your knowledge.