Question

how do I fix permission errors on a new digital ocean 1 click install?

Hello to all. I successfully installed wordpress using the tutorial located at https://www.digitalocean.com/community/tutorials/how-to-use-the-wordpress-one-click-install-on-digitalocean

Worked like a dream, except I can’t import my xml file full of posts. I successfully migrated the wp-content directory from one server to another last night but when I went to import the xml file,I got he error that it was unable to write to wp-content/uploads/2016/04

I know it’s a permissions issue but trying

Sudo chown apache:apache uploads/ failed with unknown user apache:apache.

It now turns out that I’m having issues updating the plugins due to similar permission errors. I think the two might be related. Here is an example of one of the errors when updating.

http://pasted.co/2e435bcc

I don’t have visudo set up right now so am just doing everything as root. I know I know, not safe, but doing this at 11:45 at night I wanted to get as much done before I crashed for the night. By the way I’m not exactly a beginner with ubuntu, but I’m not at intermediate either. I do know kind of what I’m doing as I dabble in Unix and Jessie.

Thanks.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Sadly that didn’t work. I’m still getting the same error I posted before. I won’t repeat it here for brevity’s sake. I did not get an error when performing the chown command though. So at least that’s progress. I’m also still getting the error of

Sorry, there has been an error. The uploaded file could not be moved to wp-content/uploads/2016/04.

Restarting apache2 did not work either. I’m stuck here as I’ve been googling around since about 11:45 last night trying to solve this problem.

It sounds like you’ve got the problem figured out and updating the ownership of the files should resolve it. On Ubuntu, the default user apache runs as is “httpd” so running:

chown -Rf www-data:www-data uploads/

should resolve the problem.