Question

How do i install my ssl correctly on my Apache Webserver

  • Posted June 17, 2014

Hello Gurus,

I paid my ssl renewal with Comodo last week and since this date I did not succeed to install it correctly. My website is still unavailable. I had to configure the SSL Certificate on my Server. As I tried to access the site using Firefox, I got the following error message : Error code: ssl_error_rx_record_too_long. I followed the the following link to troubleshoot this issue https://support.comodo.com/index.php?/Default/Knowledgebase/Article/View/630/0/firefox-error--12263-ssl_error_rx_record_too_long

I changed the virtualhost port. Here is the error message I have after doing this : [warn] NameVirtualHost *:443 has no VirtualHosts. It seems that I’m facing problem on configuring the VirtualHosts.

My Server version: Apache/2.2.15 (Unix) OS : CentOS6

Please help

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi ALexandre, thanks for your reply.

DO you think every commercial ssl work the same way? Mine is comodo ssl.

I suggest you to watch a video tutorial. The process itself is simple but require a lot of attention when copying and issuing keys. Also, don’t forget to setup a virtual host in your server to answer for HTTPS.

Rapid SSL has a extensible guide for all know platforms, you can check it out: <a href=“https://knowledge.rapidssl.com/support/ssl-certificate-support/index?page=content&id=SO16226&actp=LIST&viewlocale=en_US”>https://knowledge.rapidssl.com/support/ssl-certificate-support/index?page=content&id=SO16226&actp=LIST&viewlocale=en_US</a>

Hi Astarr thanks for your reply.

I talked to Comodo Support team. They asked me to generate a new private key and I send the CSR to them. They replace it and re-issue the certificate to me once again. Unfortunately I got the following error : unable to load certificate 139713031198536:error:0906D06C:PEM routines:PEM_read_bio:no start line:pem_lib.c:703:Expecting: TRUSTED CERTIFICATE

I’d like to mention that this is the fifth time I went over this process and I’m still have the same error message. It looks like my private key generated by my web server is not the same as comodo crt.

Regards

Could you post your VirtualHost? It will help us figure out what the issues is. Generally though, the warning: <pre> [warn] NameVirtualHost *:443 has no VirtualHosts. </pre> shouldn’t be an issue. It’s just a informational warning. After making the change, can you access your site over https? You should be able to silence it by making sure your VirtualHost is defined like: <pre> <VirtualHost *:443> </pre>