Question

How do I know which PHP version I'm using and how to update it?

  • Posted on January 22, 2015
  • lollo90Asked by lollo90

Hello, I’m very very new to web development and computing world and I’ve got a very basic question. I need to create a web app which supports login with Facebook. In order to do that, I need to use php. Although, Facebook api need php5.4+ How do I know which version of php is supported from my server? Besides, If it’s not 5.4+ how do I update it?

Thanks a lot for your support.

Greets,

Giacomo

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Here’s a quick cheat sheet that shows the base versions of PHP offered in some major distros:

Distro PHP Version
Ubuntu 12.04 5.3.10
Ubuntu 14.04 5.5.9
Ubuntu 16.04 7.0
CentOS 6 5.3.3
CentOS 7 5.4.16
Debian 7 5.4.45
Debian 8 5.6.20

If you need a more recent version, there are a number of third party repositories that offer them. For instance, these articles will walk you through upgrading to PHP 7 on Ubuntu 14.04 and CentOS 7:

RE: “How do I know which PHP version I’m using?”

When logged in to the server

php -v

will show you the PHP version information