Question

How do I redirect the server to index.php instead of index.html in Ubuntu 18.04

I am trying to open index.php instead of index.html if it is there when I enter the IP address of the webserver. I have put DirectoryIndex index.php in /etc/apache2/httpd.conf and it hasn’t worked.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @amiraAngler,

This might be a dumb question but did you remember to restart Apache after the changes you did?

One other thing, the changes for the DirectoryIndex should be made in /etc/apache2/mods-enabled In the dir.conf file. Can you try making them there and restarting apache afterwards to see if this would help you out?

Regards, KFSys