Question

How do I setup SMTP on a Discourse Droplet ?

Just installed the Discourse droplet, changed the root password, and followed the prompts. I was asked for SMTP information and thought it was as simple as using the default, adding my email address, and be done with it. However, emails are not being sent.

Is there another step that I missed?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi, I’m also having difficulty getting the registration email to work for the admin account.

I’m using Zoho as my email provider. I have successfully configured DKIM and SPF. The production.log file shows this where the email address is a valid address.

Sent mail to testemailaddress@mydomain.net (1449.1ms) Job exception: end of file reached

Any suggestions? I read through the questions and answers in https://meta.discourse.org/t/troubleshooting-email-on-a-new-discourse-install/16326 without luck. Here is a snippet of app.yml.

DISCOURSE_DEVELOPER_EMAILS: 'testemailaddress@mydomain.net'

## TODO: The SMTP mail server used to validate new accounts and send notifications
DISCOURSE_SMTP_ADDRESS: smtp.zoho.com
DISCOURSE_SMTP_PORT: 587
DISCOURSE_SMTP_USER_NAME: testemailaddress@mydomain.net
DISCOURSE_SMTP_PASSWORD: "longpasswordforaboveusername"
#DISCOURSE_SMTP_ENABLE_START_TLS: true # (optional, default true)

I have the same problem. I’ve almost completed the Discourse setup, but I can’t log in and complete the process because the confirmation email never sends. My mail server (and web host) are 1and1. I used app.yml to change the port from 587 to 25, as advised on another forum post, but that didn’t work. Does anyone have a fix for this? I’m blocked.

app.yml
cd /var/discourse
./launcher rebuild app

This comment has been deleted

I have the same question as the original poster. And, if I may say so, I feel that Andrews does not answer the question.

I am quite happy to have you handle my mail server but at the first SSH sign-in I was asked for my SMTP settings and I think I may have given the wrong port.

How can I change the SMPT port now?

Thank you and

Hello,

Configuring and administering a mail server on your own is not always an easy, straight forward task. We have a great tutorial/article about some of the issues you might run into: https://www.digitalocean.com/community/tutorials/why-you-may-not-want-to-run-your-own-mail-server

If you DO decide you want to run your mail server after reading that article, we have a lot of articles about different options to setup a mail server: https://www.digitalocean.com/community/search?q=mail+server. Depending on your skill level I would either suggest mail in a box (https://www.digitalocean.com/community/tutorials/how-to-run-your-own-mail-server-with-mail-in-a-box-on-ubuntu-14-04) for an easier solution or send-only postfix (https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-postfix-as-a-send-only-smtp-server-on-ubuntu-16-04) for a more advanced solution.

Regards,

–Andrew