Question

How do I troubleshoot failed app platform deploys?

I am having an app platform deploy failure that is resulting in repeated rollbacks, but all of the visible logs show my application starting normally. Is there any way to troubleshoot mysterious app deploy failures? I have yet to find any clear indicator of the cause in the logs in the web UI, despite multiple failures. Most deploys work fine, making the seemingly random failures all the more mysterious.

This is making me afraid to deploy mission-critical apps to this platform, because when failures happen they seem random and are not reflected in the visible logs. What am I missing?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

At least in my case this issue was because I made a worker but it was setup as a web service. The error messages and reason why it failed was very unclear, and literally in the logs I could see it try to work.

After changing the app to a worker I had not issues.

I have raised a ticket and am having same issues. Not at all helping. Planning to move to render.com soon.

This happens to me all the time too. I’ve tried working with DO support and they have suggested updated the failure_threshold in my app spec, but this doesn’t seem to have helped. I still get deploy errors all the time, usually with nothing significant or useful in the logs.