Question

How do I UPDATE Word Press? I'm running LEMP, Ubuntu 12.04, Nginx?

I just want to update wordpress. As stated in the subject, I’m running a LEMP stack with Ubuntu 12.04, Nginx …etc.

How do I go about updating wordpress to the newest version? Thanks!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@ Ben, <br> <br>The plugins update without an issue. They do not ask for FTP info. <br> <br>How do I add these permissions? I’ve never had to do that before. <br> <br>@ Jon, <br> <br>I’m trying to update it as a root user. So shouldn’t the root user have all permissions? I didn’t know it installed WP on the database under a specific user. I thought WP was installed on the server, then you create different users and set their permissions on the server to access those files. <br> <br>Thanks for your help!

@shaneharder, are you trying to update and the site is asking for FTP details? <br> <br>If so its a bit of a misnomer. Its more likely to be that you dont have the correct file and directory permissions on your WP installation for WP to update itself. <br> <br>They need to be: <br> <br>files 644 <br>directories 755 <br> <br>To confirm, if you try and add a plugin from the WP Dashboard does it ask you for FTP too?

Is your SFTP user the same user your website is running as?