Question

how fix error: DNS problem: SERVFAIL looking up A for [domain]

Posted February 20, 2018 26.5k views
ApacheDebian

the same error:

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: juancarlosmx.xyz
Type: connection
Detail: DNS problem: SERVFAIL looking up A for juancarlosmx.xyz

Domain: www.juancarlosmx.xyz
Type: connection
Detail: DNS problem: SERVFAIL looking up CAA for juancarlosmx.xyz

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

/////////////////////////
*In my domain record is: *

the command is: /usr/local/letsencrypt# sudo ./letsencrypt-auto –apache -d www.juancarlosmx.xyz -d juancarlosmx.xyz

*How fix error? *

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
5 answers

In the DNS control panel, the domain is called “www.juancarlosmx.xyz”. Therefore, things like “juancarlosmx.xyz” or “abc.juancarlosmx.xyz” don’t resolve, because they’re outside “www.juancarlosmx.xyz”.

You need to rename the domain to “juancarlosmx.xyz” (and create a “www” record in it).

If DigitalOcean doesn’t support renaming domains, you should add a new one and delete the old one.

  • Thanks, this helped me. I added the following two records. I originally had one, and it gave me errors.

    Type Hostname Value TTL (seconds)

    A www.example.com xxx.xxx.xxx.xxx 3600

    Type Hostname Value TTL (seconds)

    A example.com xxx.xxx.xxx.xxx 3600

Add an A record for juancarlosmx.xyz

*thanks for answer *… but in my page digitalocean.com section domain, exist record Hostname as : type: A and Hostname as www.juancarlosmx.xyz, get same error with:

if run /usr/local/letsencrypt# sudo ./letsencrypt-auto –apache -d www.juancarlosmx.xyz

*is same error. *

I followed this link instructions:

https://www.hostinger.com/tutorials/dns/how-to-check-if-domain-a-record-is-pointed-correctly-using-console

(Pinged the domain name and typed the IP in Digital Ocean A record and got a 404 error, which is OK! Since I haven’t add any page to nginx server)

Submit an Answer