How fix in centos 6.5 32 bits: Error: cannot find a valid baseurl for repo: rpmfusion-free

March 30, 2014 11k views
I have a droped and when i try to update yum or try to run this comand: sudo yum install sd-agent I get: Loaded pluings: fasestmirrors Determining fastest mirrors Error: cannot find a valid baseurl for repo: rpmfusion-free How i can fix this?
2 Answers
You seem to have added the RPM Fusion repository incorrectly. Let's start clean. First remove the repo with:
rpm -e rpmfusion-free-release
Then re-enable it using:
rpm -Uvh http://download1.rpmfusion.org/free/el/updates/6/i386/rpmfusion-free-release-6-1.noarch.rpm
Are you still seeing the error? What's the output of: 'yum repolist enabled '
  • That worked for me. The other site I looked at said do:
    rpm -ivh http://download1.rpmfusion.org/free/el/updates/6/i386/rpmfusion-free-release-6-1.noarch.rpm  
    What is difference with the "i" an "U"
  • What is the non-free site?
  • "i" is for "install" and "U" is for upgrade. Either should work in this case. The non-free repo contains software that is legally distributable, but not "Free Software" as in open source and freely modifiable.

[root@cpanel ~]# rpm -e rpmfusion-free-release

                          error: Failed dependencies:
    rpmfusion-free-release >= 21 is needed by (installed) rpmfusion-nonfree-release-21-1.noarch

i am receiving this error

Have another answer? Share your knowledge.