How install GLIBC 2.29 or higher in Ubuntu 18.04

I’m trying to run my python script on my Ubuntu 18.04 but when I try, I get the following error:

OSError: /lib/x86_64-linux-gnu/ version `GLIBC_2.29' not found (required by /home/user/.local/lib/python3.6/site-packages/opencc/clib/lib/

Which is that one of the modules I use (opencc) needs GLIBC 2.29 or superior.

Ubuntu “standard” version is 2.27, so I checked if I could install the updated but I can’t.

apt-cache madison libc6
     libc6 | 2.27-3ubuntu1 | bionic/main amd64 Packages

I downloaded libc-bin_2.30-0ubuntu2_amd64.deb and tried to install with sudo dpkg -i libc-bin_2.30-0ubuntu2_amd64.deb but also errors out due to lack of lib6:amd64…

(Reading database ... 101424 files and directories currently installed.)
Preparing to unpack libc-bin_2.30-0ubuntu2_amd64.deb ...
Unpacking libc-bin (2.30-0ubuntu2) over (2.30-0ubuntu2) ...
dpkg: dependency problems prevent configuration of libc-bin:
 libc-bin depends on libc6 (>> 2.30); however:
  Version of libc6:amd64 on system is 2.27-3ubuntu1.

dpkg: error processing package libc-bin (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Errors were encountered while processing:

and I tried install libc6-amd64_2.30-0ubuntu2_i386.deb but I get

dpkg-deb: error: 'libc6-amd64_2.30-0ubuntu2_i386.deb' is not a Debian format archive
dpkg: error processing archive libc6-amd64_2.30-0ubuntu2_i386.deb (--install):

So, as title, How install GLIBC >=2.29 in Ubuntu 18.04?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @RaphaelDDL,

By default, the highest version of GLIBC for Ubuntu 18.04 should 2.27. You have two options to continue :

  1. The first option is to migrate your application to a system that supports GLIBC higher than or equal to 2.29. This would mean a lot of work though. It seems Ubuntu 19.04 actually uses that version.

  2. The second option would be to actually build your GLIBC from source using the version you want or need. I’ve researched it a bit and found a website which actually gives you the steps for you to build the package from source :

Take a look at it and decide how it would be best for you to proceed.

Regards, KDSys

echo “deb testing main contrib non-free” >> /etc/apt/sources.list

apt-get update apt-get install build-essential -y

Hope that help