How set up my FQDN? (Ubuntu 12.04)

March 8, 2014 2.8k views
Hi. I'm trying to set up my FQDN to get my mailserver to work. When I type # hostname I get "rakuraku" When I typ # hostname -f I get "localhost" my /etc/hostname file is: " raku" Are there some settings stored otherwhere, since I get rakuraku from hostname -f, which I probably entered somewhere during the setup of my server? Thank you!
2 Answers
/etc/hostname should only contain the hostname itself:

/etc/hosts should also contain the following line: raku
Have another answer? Share your knowledge.