Question

How to active sudo a2enmod rewrite for centos?

  • Posted October 17, 2013

Following the tutorial “How To Set Up Mod_Rewrite” indicates I should run the command “sudo a2enmod rewrite”, but I mark: sudo: a2enmod: command not found

anyone know how to fix it?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Using .htaccess files and setting AllowOverride All is not recommended. It’s better to put the rewrite commands in your Directory section in httpd.conf. To enable the rewrite engine in this context, you need to set “RewriteEngine On” and “Options FollowSymLinks” must be enabled. (From: http://httpd.apache.org/docs/2.2/mod/mod_rewrite.html#rewriterule) <br> <br>This is what did it for me

In httpd.conf, search for <code>AllowOveride None</code> and change to <code>AllowOveride All</code>, then restart apache. <br>

Hi there, it seems no way to enable it on CentOS, see this for more information:http://serverfault.com/questions/558600/centos-bash-a2enmod-command-not-found

is there still no install package for centos/rhel?

I am totally new at this and I am trying to fix it based on the fact that wordpress is telling me page not found errors (saw on a forum that my mod_rewrite must be off) So I started following this directions: https://www.digitalocean.com/community/tutorials/how-to-set-up-mod_rewrite but it gave me this message

3 packages can be updated. 3 updates are security updates.

Last login: Sun Apr 12 20:49:18 2015 from host-68-169-131-190.cmgolt1.epbfi.com ####################################################################

Careful, you’re logged in as root!

* Do not create app files or install apps as root.

* Customizations may break your server.

https://serverpilot.io/community/articles/root-user-guide.html

#################################################################### root@KCSC:~# sudo a2enmod rewrite sudo: a2enmod: command not found root@KCSC:~# sudo a2enmod rewrite sudo: a2enmod: command not found root@KCSC:~#

Dunno what to do now.

Hello Kamal Nasser! <br> <br>I tryed this, but still is not work . . another idea??

Uncomment the mod_rewrite.so line in <code>/etc/httpd/conf/httpd.conf</code>, restart apache, and you should be good to go.