Question

How to block IP range or country with firewalld?

Hello,

How can I block IP range or entire country on CentOS 7 with FirewallD? The IP range starts with 180.76.15.* and is Chinese IP.

The command below works for single IP but not for range:

firewall-cmd --permanent --add-rich-rule="rule family='ipv4' source address='180.76.15.154' reject" 

I tried with this command for the range but without success:

firewall-cmd --permanent --add-rich-rule=“rule family=‘ipv4’ source address=‘180.76.15/24’ reject”

Cheers


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I think the correct command is:

firewall-cmd --permanent --add-rich-rule="rule family='ipv4' source address='180.76.15.0/24' reject"

Pay attention to highlighted part

Yeah, I have an idea, why not utilize “UFW” or iptables (conntrack allows the user to log access).

dnf install ufw -y systemctl enable --now ufw systemctl start --now ufw

ufw enable

ufw insert 1 deny in from 180.76.15.0/24 to any comment "Block China Access" # Blocks TCP and UDP access

iptables

iptables -I INPUT 1 -p all -s 180.76.15.0/24 -m conntrack --ctstate NEW,RELATED,ESTABLISHED -j REJECT

This comment has been deleted