How to change the document root directory in debian8.1?

My apache2 installed on the debian8.1. In the configuration file /etc/apache2/apache2.conf

<Directory /> Options FollowSymLinks AllowOverride None Require all denied </Directory>

<Directory /usr/share> AllowOverride None Require all granted </Directory>

<Directory /var/www/> Options Indexes FollowSymLinks AllowOverride None Require all granted </Directory>

There are lines in the index.html:

The default Debian document root is /var/www/html. You can make your own virtual hosts under /var/www. This is different to previous releases which provides better security out of the box. With phpinfo() to get document root is /var/www.

How to change it into /var/www ?In the /etc/apache2/apache2.conf,it is already <Directory /var/www/>, but in fact the document root is /var/www/html.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

You need to edit the site specific config file at this path /etc/apache2/sites-enabled

the file you probably need to edit is 000-default.conf

just change the DocumentRoot from /var/www/html to /var/www/YOUR_DIRECTORY