How to config mup.json (mupx setup/deploy error)

July 29, 2016 335 views

I am going to upload my meteor app here with mupx,
// Server authentication info
"servers": [
"host": "", // IP address copy from droplets
"username": "root",
"password": "mypasswordofroot",
// or pem file (ssh based authentication)
// WARNING: Keys protected by a passphrase are not supported
//"pem": "~/.ssh/id_rsa"
// Also, for non-standard ssh port use this
//"sshOptions": { "port" : 49154 },
// server specific environment variables
"env": {}

// Install MongoDB on the server. Does not destroy the local MongoDB on future setups
//"setupMongo": true,

// Application name (no spaces).
"appName": "ezafah",

// Location of app (local directory). This can reference '~' as the users home directory.
// i.e., "app": "~/Meteor/my-app",
// This is the same as the line below.
"app": "G:/EZAFAH/ezafah",

// Configure environment
// ROOTURL must be set to your correct domain (https or http)
"env": {
"PORT": 80,
URL": ""

// Meteor Up checks if the app comes online just after the deployment.
// Before mup checks that, it will wait for the number of seconds configured below.
"deployCheckWaitTime": 600,

// show a progress bar while uploading.
// Make it false when you deploy using a CI box.
"enableUploadProgressBar": true

when i uncomment "setupMongo": true, it gives error and at this time when i comment this line
mupx setup (command is done)
mupx deploy --settings=settings.json
gives error, please help me.

1 comment
  • What are the errors you are getting with these different settings commented or un-commented?

1 Answer

Without further information it's difficult to give you a definitive answer on how to correct the error you are getting. I would recommend checking out a guide like this one to walk you through deploying your meteor app with mupx.

Have another answer? Share your knowledge.