Question

How to connect to managed database over private network?

Posted March 4, 2020 120 views
NetworkingDatabases

I have set up a managed database in SFO2 and I have a droplet in SFO1. I added the droplet as well as its public and private IP addresses as allowed sources. Connecting via the public network works great. When I try to connect via the private network, it just hangs, as you would expect if you were being blocked by a firewall.

I’ve even tried:
nc -zv ${privatehostname } ${port}
and its still not connecting.

Is there something I’m missing here?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

The private networks for SFO1 and SFO2 are entirely separate. You would only be able to communicate with your managed database over the private network from a Droplet in SFO2.

With that in mind, you could either create new Droplets in SFO2, or communicate over the public network.

  • Eris
Submit an Answer