Hi,

I tried to execute CREATE EXTENSION lo; in my db instance with the doadmin user. However it returns:

ERROR: permission denied to create extension “lo”
HINT: Must be superuser to create this extension.
SQL state: 42501

I found that the doadmin is not a superuser. How can I grant superuser privilege to doadmin? If I can’t, is there any solution?

edited by bobbyiliev

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there

Thanks for reaching out to DigitalOcean Support. 

I understand you want to install lo extension to PostgreSQL managed database. lo extension is supported in managed postgresql database v12. Please upgrade your postgresql database version if you are still at older version.

DigitalOcean PostgreSQL Managed Databases supports the following extensions mentioned in below link. This list is current as of the Validated date on this page.

https://www.digitalocean.com/docs/databases/postgresql/resources/supported-extensions/



Please let us know if you have additional questions/concerns.

Regards
Priyanka
DigitalOcean Support

Submit an Answer