Question

How to debug Error 521 on a Ghost 1-Click droplet?

Hello,

A few hours ago I set up a new Ghost 1-Click droplet. Everything went fine and I can SSH in, update, etc without issue. However, after updating my A record at CloudFlare, and waiting a few hours, the site is still not loading (Error 521).

When I do ghost ls status does indicate running. Any ideas what else I can test? CF shouldn’t take more than a few minutes to propagate I think? And I did the manual DNS flush (locally and on CF’s 1.1.1.1 flush tool).

Can anyone provide any pointers please? Thanks kindly

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I made sure that all CF IP’s are in the whitelist and also opened up port 443. Still no luck. :/

One thing I did notice - when I set SSL to Off on CF, the url in question fails with a redirection error. Not sure what that would mean tho?