How to debug/solve a "ERR_CONNECTION_TIMED_OUT" error when this error happens on some browsers but not in another?


I am managing a Droplet that hosts a light website named “”. I’ve seen this page working perfectly fine a few days, but one of the customers says he can not see the page, no matter what browser he uses, no matter how many times he clears each browser’s cache, cookies, etc. from the beginning of time.

In the beginning I thought this was a local customer network issue, because while he was not able to see the page, I was, as well as many other clients in different networks and geographical areas. I rebooted the droplet once, and then the customer that said that could not see the page now was able to see it normally, but after a few minutes, he received the same error again.

But today I’m having the same issue. I can not access that page from Google Chrome, Firefox, Internet Explorer nor Opera. I don’t have any web-site blocking component (firewall, proxy, etc.) and I have not changed anything on the droplet (again, I’m the only one administrating it). Now if I reboot the droplet it does not seem to help.

I installed Tor browser, enabled JavaScript, Cookies and Plugins, and from there I can access the page as expected. One of the customers said that when accessing using some kind of plugin to hide the real location/identity of the browser, the page loaded fine. I did not configure any kind of restriction to this application or apache server to cause that.

Here are some tests I’ve made:


Pinging [] with 32 bytes of data:
Reply from bytes=32 time=124ms TTL=51
Reply from bytes=32 time=122ms TTL=51
Reply from bytes=32 time=122ms TTL=51
Reply from bytes=32 time=135ms TTL=51

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 122ms, Maximum = 135ms, Average = 125ms


Tracing route to []
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms
  2    79 ms    29 ms    42 ms []
  3    11 ms    12 ms    37 ms
  4    15 ms    55 ms    52 ms []
  5   140 ms    79 ms    79 ms
  6    86 ms    85 ms   108 ms
  7    87 ms    89 ms   127 ms []
  8    90 ms    89 ms   125 ms []
  9    97 ms   114 ms   111 ms []
 10   129 ms   122 ms   154 ms []
 11   155 ms   118 ms   116 ms []
 12   127 ms     *      142 ms []
 13   120 ms   120 ms   139 ms []
 14   141 ms   131 ms   125 ms []
 15   123 ms   103 ms   108 ms
 16   139 ms   140 ms   122 ms []

Trace complete.

Also, here is the website’s Zone file content (as displayed by DigitalOcean in the DNS management page):

$TTL 1800 IN SOA 1435073711 10800 3600 604800 1800 1800 IN NS 1800 IN NS 1800 IN NS 1800 IN A 1800 IN CNAME
* 1800 IN CNAME

I have normal access via SSH, the Apache service is running, PHP is ok as well, I’ve extended the timeout settings in PHP to around 2 minutes, but the “ERR_CONNECTION_TIMED_OUT” error appears before that time in most of the cases. The databases are working fine as well.

Checking the server status via HTOP, I see the server is running fine, using less than 5% of the CPU, and around a 25% of the RAM (4 GB in total):

root@onlyonecolombia:/var/log/apache2# htop

  1  [|                            1.3%]     Tasks: 102, 48 thr; 1 running
  2  [                             0.0%]     Load average: 0.06 0.03 0.05
  Mem[|||||||||||||          906/3953MB]     Uptime: 01:42:57
  Swp[                            0/0MB]

Apache access and error logs do not show irregularities. The only thing I noticed there is that when I try to access the application from one of the browsers with the problem, the access log in apache does not move. I see that by using

root@onlyonecolombia:/var/log/apache2# tail -f -n 500 access.log

The same goes for the error log: no entries when accessing from a browser with the problem.

One thing to note, is that I installed iRedMail right after creating the droplet, because I needed this droplet to have a Mail server for that domain as well, which so far is working just fine.

We have SSL configured for this website, and internal redirection from HTTP to HTTPS in the main application, which is working fine too.

I’m running out of options here, and of course I can not tell all customers to use Tor browser to access this specific website, so I would like to ask for any advice here. If there is anything I’ve missed please let me know.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This happened to me too. Fixed it by uninstalling fail2ban and purging it’s cache:

same issue over here!!!

Does anyone get the solution for this? I faced a similar problem but did not get any relevant solution for this.