How to delegate a subdomain to another DNS provider ?

Posted July 18, 2015 6.1k views

I try to delegate a subdomain of a domain to aws Route 53. I do not seem to be able to create a zone for the subdomain to enter the NS records. How would I do that ?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Good news: This answer is outdated!

I just created a subdomain and I was able to create a NS record and point it to a different DNS. It actually works.

  • I tried this now and was unsuccessful. I mean, the creation of new NS records are successful, but they do not resolve.

    dig returns no results.

    After adding new records at the other provider, those do not resolve either.

    Do you still use sub-domain delegation @hmgauna ?

    • Hi Shine! I think I might not have explained it right but it does still work.

      What I made was to add the subdomain within the domain records in Digital Ocean. I am attaching the details in case it helps you:

      NS directs to  
      NS directs to 

      I wonder if it is exactly the oppposite case (you are trying to delegate your subdomain from another provider to Digital Ocean)? But I guess you should be able to set it in the same way. In case you are redirecting form another provider, have you already created a domain in Digital Ocean resolving to your droplet? In fact, you can go ahead and set the domain = sub.domain instead of adding additional records.

      • I understood what you meant in your first comment. I am not looking to delegate my sub-domain from another provider to DigitalOcean. I am looking to forward my sub-domain from DigitalOcean to another provider.

        I tried diging the domain that you provided here and I did not get any results either.

        • I don’t know why the dig command does not resolve, but I this solution works for sure.

          If you check and then check []( you will notice that they resolve to different IPs.

          Internally, I am sending the subdomain to my shared hosting NS server (because it does not have a fixed IP). However, Digital Ocean’s DNS seem to show only the resulting IP (it seems to be publicly available as an A record), but not the NS record that I set up.

          PS: I dig both domains from my console and could see the resulting IP.

          • This was my bad. I was suppressing the complete output for dig with the +noall +answer options. Removing the options and then digging with the DigitalOcean nameserver ( ) revealed the NS records in the AUTHORITY SECTION.

Unfortunately our DNS system does not currently support subdomain delegation. User feedback plays a major role in what features we develop so I encourage you to submit this to our user voice so others can vote on it.

Currently it is possible to delegate a subdomain from another provider to DO and create a zone for that subdomain.