Question

How to disable custom log on Apache

<VirtualHost *:80>
    ServerName www.website.com
    ServerAlias website.com
    DocumentRoot /var/www/website.com/public_html
    ErrorLog /var/www/website.com/error.log
    CustomLog /var/www/website.com/requests.log combined
</VirtualHost>

Hi,

I must disable my “CustomLog” line. I tried to removed that line from; /etc/httpd/sites-available/mywebsite.com.conf and restarted apache. But nothing changed.

I jsut want to stop logging on my server. How can I make it?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You might have to comment out “ErrorLog” and “CustomLog” line in virtual host entry in your web configuration file. You can restart the apache and logging should be disabled. If not, then please get in touch with the support team to investigate further:

https://www.digitalocean.com/company/contact/#support

how can I edit sites-enabled files?