Question

How to disable Secure Boot in Ubuntu 20.04 Droplet (difficulties with virtual camera installation)

Hello, sorry if this question doesn’t have a place here - I think I’m running into an issue that has to do with the fact that the server is a linux VM.

I am currently trying to set up the virtual camera in OBS Studio on my Ubuntu 20.04 virtual machine (DigitalOcean droplet) by installing the v4l2loopback-dkms module. However, although the virtual camera button is appearing in the OBS software, clicking it does nothing, as described in this Stack Overflow question. Here is a log of what occurs when I install the v4l2loopback module:

ramy@opal-cafe:~$ sudo apt -y install v4l2loopback-dkms v4l2loopback-utils
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed: [ABRIDGED]
Suggested packages: [ABRIDGED]
The following NEW packages will be installed: [ABRIDGED]
0 upgraded, 38 newly installed, 0 to remove and 65 not upgraded.
Need to get 37.6 MB of archives.
After this operation, 173 MB of additional disk space will be used [ABRIDGED]
Fetched 37.6 MB in 1s (33.1 MB/s)               
Extracting templates from packages: 100%
[ABRIDGED]
Setting up build-essential (12.8ubuntu1.1) ...
Setting up v4l2loopback-dkms (0.12.3-1ubuntu0.4) ...
Loading new v4l2loopback-0.12.3 DKMS files...
Building for 5.4.0-107-generic
Building initial module for 5.4.0-107-generic
Can't load /var/lib/shim-signed/mok/.rnd into RNG
139665634772288:error:2406F079:random number generator:RAND_load_file:Cannot open file: ../crypto/rand/randfile.c:98:Filename=/var/lib/shim-signed/mok/.rnd
Generating a RSA private key
............................................................+++++
...............................+++++
writing new private key to '/var/lib/shim-signed/mok/MOK.priv'
-----
EFI variables are not supported on this system
/sys/firmware/efi/efivars not found, aborting.
Done.

v4l2loopback.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.4.0-107-generic/updates/dkms/

depmod...

DKMS: install completed.
Processing triggers for libc-bin (2.31-0ubuntu9.7) ...
Processing triggers for man-db (2.9.1-1) ...

After uninstalling and reinstalling both the v4l2loopback module and OBS Studio a few times in different ways to no avail, as well as using sudo modprobe v4l2loopback, I tried the suggestion to disable secure boot via this method. However, when I try to check for the secure boot state using mokutil --sb-state, I encounter this error:

EFI variables are not supported on this system.

Other suggested methods of disabling Secure Boot were to disable it from BIOS, but I’m not sure how to access that, this being a virtual machine (I’m using xrdp with Gnome desktop to get a GUI). If anyone has any suggestions on what I can do next, please let me know - I’m pretty new to Ubuntu and am going in blind.

Adding a follow-up here: when I run sudo modprobe v4l2loopback, I get this error:

modprobe: ERROR: could not insert 'v4l2loopback': Unknown symbol in module, or unknown parameter (see dmesg)

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer