Question

How to enable curl_multi_exec() ?

Posted December 1, 2018 1.1k views
PHPUbuntu 16.04

Hi,

I am using social warfare plugin with Ubuntu 16.04.4 x64 & while using it it always shows

Warning: curlmultiexec() has been disabled for security reasons in /home/setupserver/applications/XYZ/public/wp-content/plugins/social-warfare/lib/utilities/SWP_CURL.php on line 71

I have already install PHP CURL via Console with below code but it still shows same error.

Please guide me how can I enable it ?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello,

You could try enabling the curl_exec function. You could do that via your php.ini file.

To find your php.ini file either run: php -i | grep php.ini or create an info php file.

Then edit the php.ini file with your favourite text editor and look for disable_functions. You would need to remove the curl_exec from the list:

disable_functions = (Remove curl_exec from here)

Regards,
Bobby

Submit an Answer